Unable to Sign In Through Steam
Incident Report for Dotabuff
Resolved
Steam Community is now correctly processing authentication requests.
Posted over 3 years ago. Oct 19, 2015 - 12:19 UTC
Monitoring
We've confirmed reports that there are currently issues signing into Dotabuff through Steam Community. This appears to be a Steam-wide issue across a few regions.
Posted over 3 years ago. Oct 19, 2015 - 11:06 UTC