Payments and refunds not processing
Incident Report for Dotabuff
Resolved
A fix has been deployed by Stripe and we no longer expect any issues related to payments. If you are still experiencing issues or if you are not sure whether your payment or cancellation has been confirmed, please get in touch with our support team at support@dotabuff.com.
Posted over 3 years ago. Oct 08, 2015 - 01:45 UTC
Monitoring
Our payment processor Stripe is currently experiencing difficulties. They are aware of the problem and working on a fix. Please contact our support team at support@dotabuff.com if you are not sure whether a payment/cancellation has gone through. Sorry for any inconvenience.
Posted over 3 years ago. Oct 08, 2015 - 01:17 UTC