China (Perfect World Telecom) Replays
Incident Report for Dotabuff
Resolved
This incident has been resolved.
Posted almost 4 years ago. Oct 04, 2015 - 08:49 UTC
Identified
Replay downloads in the China (Perfect World Telecom) region are failing. TrueSight analysis for some matches played in the region may be unavailable.
Posted almost 4 years ago. Oct 03, 2015 - 18:59 UTC