Replays Unavailable
Incident Report for Dotabuff
Resolved
This incident has been resolved.
Posted over 4 years ago. Mar 20, 2015 - 03:34 UTC
Monitoring
Steam has become responsive again and we're processing a backlog of replays. TrueSight analysis for new matches may be delayed until the backlog is cleared.
Posted over 4 years ago. Mar 19, 2015 - 22:47 UTC
Identified
Steam is currently experiencing issues, causing replays to be unavailable. TrueSight analysis for matches will be delayed until this is resolved.
Posted over 4 years ago. Mar 19, 2015 - 17:43 UTC